Paint not rendering with .vdc files

I have a bunch of binary data files with dimensions 1200x1200x400 (encoding velocity, magnetic field components and temperature). So I used the vdccreate command in the terminal to create an empty file with a list of 3 variables (x,y, and z compenents of velocity). And then I used the raw2vdc command as suggested in the documentation for all the 3 variables to store in the original file. But the issue I am facing is that when I try to render the image in the VAPOR GUI, the empty box dimension doesn’t appear after loading the file (as it does for other files), and when I try using the Volume renderer, it gives the following error: “Paint failed”, and in the logs, it says “error performing paint event”. However, I later tried it with just one variable (z velocity component) instead of all three, and it worked. I don’t seem to understand what the issue is. Any help would be greatly appreciated.

Could you share the vdccreate command you used, as well as all of the raw2vdc commands that followed?

Yes, the vdc command I used is:

vdccreate -dimension 1200x1200x400 -vars3d U:V:W velocity.vdc

and the raw2vdc commands are:

raw2vdc -ts 1 -varname U velocity.vdc result_prim_1.072400
raw2vdc -ts 1 -varname V velocity.vdc result_prim_1.072400
raw2vdc -ts 1 -varname W velocity.vdc result_prim_1.072400

(where ‘result_prime…’ is just the binary filename with the variables)

That looks legitimate to me. I know your files are large, but you would be able to share one of them so I can try to reproduce your error?

I have uploaded the file in this google drive link.
This is the z-velocity component.

The problem was the -ts 1 flag in raw2vdc, which is an offset from the first timestep. This should be 0, or omitted since 0 is the default.

Vapor should probably be warning users when it receives invalid arguments though, so I’ll submit a ticket to make this error more obvious.

raw2vdc -ts 0 -varname W velocity.vdc result_prim_1.072400

Thank you for bringing this problem to our attention and let us know if there are further issues.

Thanks a lot! It worked perfectly now.