Strange behaviour wrf-output

I am trying to visualize 3d field from wrf-output netcdf using Volume renderer, but instead I get the following 2d “mesh”, see Fig. 1

But when I try to render 3d field from vapor-tutorial netcdf, everything is fine, see Fig. 2.

Headers of the files are the same, see Fig. 3.

In both cases I import “WRF-ARW”.
Could someone advice on how to fix it?

Your domain is probably very small on the Z axis and needs to be stretched. In the Scene->Viewpoint tab, adjust the Z axis scale factor. IF that doesn’t work, could you share one of your files so I can take a look?

Thanks for you suggestion. Model output has 54 levels. I tried to do what you recommend. It did not help.
I have uploaded file here:

I use M1 mac book and the latest VAPOR version.

I tried the same data file on my intel macbook with VAPOR 3.7.1, and the rendering is simply a black background with a white box, seemingly nothing got rendered.

I also tried the same data file on my home ubuntu 22.04 machine with VAPOR 3.7.1. VAPOR crashes upon opening this data file.

@saneku - Is WRF-CHEM a subset of WRF-ARW? I think this might be the issue. This file has more than one timestep which we may support but I don’t recall seeing this format before. The FXLAT variable is not monotonically increasing which may contribute to VAPOR not reading your X coordinate correctly.

@shaomeng - I cannot reproduce the crash on Ubuntu 22. But Vapor’s interpretation of the X coordinate is incorrect, having extents ranging from -180 to -180 degrees longitude.

@pearse Not clear what do you mean by subset of WRF-ARW. But WRF is taking care of the all IO including IO of WRF-Chem’s chemical species and other stuff.
Did you mean XLAT variable? There is no FXLAT.
Maybe it is due to curve-linear grid. Does VAPOR support it?

@sam Thanks for trying out to visualize the file. I got the same result.